Home Forums Unicon Unicon – Google Maps not working

Home Forums Unicon Unicon – Google Maps not working

  • Creator
  • #82473


    Google Maps isn’t working anymore. And yes, I know that you answered this many times before. But when I follow the steps with the api key, deregister and so on, everything keeps blank. Error Code: “You have included the Google Maps API multiple times on this page. This may cause unexpected errors.”

    This doesn’t work:
    function wpdocs_dequeue_script() {
    wp_dequeue_script( ‘google-maps-api’ );
    add_action( ‘wp_print_scripts’, ‘wpdocs_dequeue_script’, 100 );

    function minti_load_googlemaps() {
    wp_register_script( ‘google-maps-api’, ‘//maps.google.com/maps/api/js?key=THE_GENERATED_KEY’, false, NULL, true);
    add_action( ‘wp_enqueue_scripts’, ‘minti_load_googlemaps’ );

    —> Cannot redeclare minti_load_googlemaps() (previously declared in ……./wp-content/themes/unicon-child/functions.php:58) in …./wp-content/themes/unicon/framework/inc/shortcodes.php on line 581
    —> giving it an other name will produce no php error message, but it doesn’t do anything

    Well, I didn’t buy this theme to fix everythink on myself after an update or to program something new.
    In the default version of visual composer there is the possibility to place the google maps embed/iframe code (and everything works well if I use other themes). In your theme you replaced wonderful composer plugins and functions with buggy nonworking code and the last update was a few months ago. Are you kidding? This isn’t user-friendly, this is shit!
    A good theme shouldn’t let you waste time for something that already works on default settings!
    Please reset the default function or make regularly updates!
    It would be nice If you could provide me a fix to enable the iframe-section via functions.php again.
    I don’t want to change the core code of the theme (because of updates in the future).

    Kind regards.

Sorry, only verified customers can view ticket replies.